Uma recente falha no Bluetooth foi alertada pelo Google e Intel, vêm causado um verdadeiro alvoroço, ela afeta todas, exceto a mais recente versão do kernel do Linux 5.9.

O Google e a Intel da mais detalhes em seus comunicados sobre essa falha de alta gravidade que afetam as versões mais antigas do kernel que suportam BlueZ.

"A validação de entrada inadequada no BlueZ pode permitir que um usuário não autenticado habilite potencialmente o escalonamento de privilégios por meio de acesso adjacente", observa a Intel em seu comunicado para CVE-2020-12351. BlueZ é encontrado em dispositivos IoT baseados em Linux e é a pilha Bluetooth oficial do Linux.”

A Intel que contribui com o projeto BlueZ está lançando correções para resolver está falha, bem como correções de gravidade média como CVE-2020-12352 e CVE-2020-24490.

O engenheiro de segurança da Google publicou no início da semana um tweet relatando sobre essa vulnerabilidade.

Nguyen diz que é uma falha de execução remota de código do Linux Bluetooth de "clique zero" e publicou um pequeno vídeo demonstrando o ataque usando comandos em um laptop Dell XPS 15 executando o Ubuntu para abrir a calculadora em um segundo laptop Dell Ubuntu sem qualquer ação realizada na vítima computador portátil.”

A recomendação é para atualizar, se possível o kernel utilizado em sua máquina. Leia mais no link abaixo.

Fonte: https://www.zdnet.com/article/google-warns-of-severe-bleedingtooth-bluetooth-flaw-in-linux-kernel/